В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kreizanova
Kreizanova
28.12.2022 07:54 •  Информатика

Заданы два одномерных массива А(10) и В(7). Составить программу подсчёта суммы элементов с нечётными индексами и произведения отрицательных элементов в массивах(Питон)

Ответ:
rashantixaip
rashantixaip
07.02.2022 16:07

ЕСЛИ НЕ РАБОТАЕТ КОД, СМОТРИ ФОТО

a = [1, 2, 3, -4, 5, 6, 7, 8, 9, 10]

b = [1, 2, -3, 4, 5, 6, 7]

#суммы

sumb = 0

suma = 0

for i in range(len(a)):

   if i % 2 != 0:

       suma += a[i]

print('suma a:', suma)

for i in range(len(b)):

   if i % 2 != 0:

       sumb += b[i]

print('suma b:', sumb)

print('suma a+b', suma+sumb)

# произведения

pra = 0

prb = 0

for i in range(len(a)):

   if a[i] < 0:

       if pra != 0:

           pra = pra * a[i]

       else:

           pra = a[i]

print('произведение а:', pra)

for i in range(len(b)):

   if b[i] < 0:

       if prb != 0:

           prb = prb * b[i]

       else:

           prb = b[i]

print('произведение b:', prb)

print('общее произведение:', pra*prb)


Заданы два одномерных массива А(10) и В(7). Составить программу подсчёта суммы элементов с нечётными
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?