В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Pandi2
Pandi2
03.07.2021 01:37 •  Информатика

Даны стороны двух треугольников. Напишите программу, которая находит сумму: а) периметров; б) площадей обеих фигур. С функции

Язык: питон

Ответ:
Лідія200445
Лідія200445
06.02.2022 22:31

from math import sqrt

def perimetr(a, b, c):

   return a+b+c

def ploshad(a,b,c):

   p = (a+b+c)/2

   x = sqrt(p*(p-a)*(p-b)*(p-c))

   return x

a = 12

b = 23

c = 30

a2 = 13

b2 = 11

c2 = 21

print('Сумма периметов:', perimetr(a,b,c) + perimetr(a2,b2,c2))

print('Сумма площадей:', ploshad(a,b,c) + ploshad(a2,b2,c2))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?