В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kymbat2016
kymbat2016
27.02.2022 17:15 •  Информатика

Написать в паскаль abc 1) напишите программу, перемножающую целые числа без использования операции < < * > > . например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m++m). 2) напишите программу возведения числа в целую степень. число и степень запрашивайте у пользователя.

Ответ:
ееее70
ееее70
25.06.2020 22:57
Опишу только момент, в котором вся суть, т.е. без ввода данных и т.д.:
...
for i:=1 to (на сколько надо умножить) do
k:=k+a {k-итоговая сумма, перед циклом к=0, в конце к<>0; a-вводимое число}
...
таким же образом поступаем и с умножением
0,0(0 оценок)
Ответ:
Polinka21a
Polinka21a
25.06.2020 22:57
Uses crt;
var x,y,pr,i:integer;
begin
     pr:=0;
     write('1 множитель:'); readln(x);
     write('2 множитель:'); readln(y);
     for i:=1 to x do
         pr:=pr+y;
     writeln('произведение:',pr);
end.
---
uses crt;
var x,y,st,i:integer;
begin
     st:=1;
     write('число:'); readln(y);
     write('степень:'); readln(x);
     for i:=1 to x do
         st:=st*y;
     writeln('результат::',st);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?