В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Pascal ! 1. составьте программу, вычисляющую, сколько букв надо исправить в слове х, чтобы получилось слово y (слова x и y одинаковой длины). 2. составьте программу, определения номера первой буквы "а" в слове х. 3. составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове х чаще.

Ответ:
76938
76938
25.06.2020 21:48
Задача 1.
var
  i,c: integer;
  x,y: string;

begin
  readln(x);
  readln(y);
  for i:=1 to length(x) do
    if x[i]<>y[i] then inc(c);
  writeln('Букв надо исправить = ',c)
end.

Задача 2.

var
  i: integer;
  x: string;

begin
  readln(x);  i:= 1;
  while x[i]<>'a' do inc(i);  // Здесь, в зависимости с какой буквой сравнивать, либо с русской, либо с англ.
  writeln(i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?