В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
orhideya68
orhideya68
19.05.2021 21:44 •  Информатика

На языке Паскаль составить программу для решения задач. класс в составе 25 чел. сдал экзамен по математике. необходимо внести за результаты по экзамену, посчитать средний бал, посчитать кол-во "4" и"5" вместе. кол-во "3", а вместе кол-во "2" и"1" решите

Ответ:
Eliiiii099
Eliiiii099
01.02.2022 22:36

Pascal

const  

  n=25;

var

 a:array[1..n] of integer;

 i, s0, s1, s2, s3 : integer;

begin

 randomize;

 s0:=0; s1:=0; s2:=0; s3:=0;

 for i:=1 to N do begin

   a[i]:=random(5)+1; (*если хотим ввести случайные оценки*)

//    readln(a[i]);  (*если хотим ввести оценки сами*)

   s0:=s0+a[i];

   case a[i] of

     4,5: inc(s1);

     3: inc(s2);

     1,2: inc(s3);

   end;

 end;

 writeln(a);

 writeln('Средний бал =', s0/n);

 writeln('Кол-во 4 и 5 =', s1);

 writeln('Кол-во 3 =', s2);

 writeln('Кол-во 2 и 1 =', s3);

end.


На языке Паскаль составить программу для решения задач. класс в составе 25 чел. сдал экзамен по мате
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?