В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

написать программу в которой: вводится и выводится массив из 10 рандомных чисел (от - 10 до 10). Нужно найти сумму элементов массива и максимальное значение. Вывести ответы на экран.(через паскаль)

Ответ:
bellalove200
bellalove200
31.01.2022 08:57

program test;

var i,s,m:integer;

a:array [1..10] of integer;

begin

randomize;

s:=0;  

for i:=1 to 10 do

begin

a[i]:=random(21)-10;

write(a[i],' ');

s:=s+a[i];

if i=1 then m:=a[i]

else if a[i]>m then m:=a[i]

end;

writeln;

writeln(s);

writeln(m)

end.

0,0(0 оценок)
Ответ:
KittyKittyk
KittyKittyk
31.01.2022 08:57

Программа:

Pascal:

var arr: array[1..10] of integer;

begin

 for var i := 1 to 10 do arr[i] := random(-10, 10);

 writeln('Массив: ', arr);

 writeln('Сумма элементов массива: ', arr.sum);

 writeln('Максимальный элемент массива: ', arr.max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?