В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SoMood
SoMood
07.10.2022 23:43 •  Информатика

Составить программу для нахождения произведения элементов массива Т из 8 элементов целого типа, заполнить его с клавиатуры и вывести на экран в строку через пробел. Язык программирования - Паскаль.

Ответ:
Neekeetos
Neekeetos
31.01.2022 08:46

Программа:

Pascal:

const N = 8;

var

 arr: array[1..N] of integer;

 i, pr: integer;

begin

 pr := 1;

 writeln('Введите массив из ', N, ' чисел: ');

 for i := 1 to N do begin

   readln(arr[i]);

   pr := pr * arr[i];

 end;

 

 write('Массив: ');

 for i := 1 to N do write(arr[i], ' ');

 writeln(#13#10, 'Произведение элементов: ', pr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?