В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Алентина
Алентина
14.01.2021 07:09 •  Информатика

Паскаль. Написать программу, определяющую является ли заданный массив монотонным?

Ответ:
olegkashpurozzi7v
olegkashpurozzi7v
30.01.2022 02:15

pascal

Объяснение:

var i, n, mysign, nsign: integer;

   ismon: boolean;

   a: array of integer;

begin

 Write('Введите размер массива: '); ReadLn(n);

 SetLength(a, n);

 WriteLn('Введите Элементы массива: ');

 for i := 0 to n - 1 do ReadLn(a[i]);

 mysign := sign(a[1] - a[0]);

 if mysign >= 0 then mysign := 1;

 ismon := true;

 for i := 2 to n - 1 do

 begin

   nsign := sign(a[i] - a[i - 1]);

   if nsign >= 0 then nsign := 1;

   if nsign <> mysign then ismon := false;

 end;

 if ismon then WriteLn('Массив монотонный') else WriteLn('Массив не монотонный');

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?