В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dianka27091987
dianka27091987
16.10.2020 21:44 •  Информатика

PYTH На вход программы получаем число X. Причём 10000<= X <=1000000

Напишите программу, которая находит сумму цифр числа на чётных местах и сумму цифр числа на нечётных местах (места нумеруем с 0 и справа на лево). Например:

987851

Сумма чётных = 17

Сумма нечётных = 21

Ответ:
Hause1
Hause1
28.01.2022 14:41

x = input('X: ')

summach = 0

summanech =0

for i in range(1, len(x)+1):

   if i % 2 == 0:

       summach += int(x[i-1])

   else:

       summanech += int(x[i-1])

print('Сумма чётных = ' + str(summach))

print('Сумма нечётных = ' + str(summanech))

Чуть поменял прогу.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?