Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
vadim252525
08.02.2021 03:49 •
Информатика
Составить программу для решения следующей : дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. замените все отрицательные элементы максимальным. выведите на экран исходный и измененный массивы.
Ответ:
Niki152
25.06.2020 17:59
var
i,max:integer;
ar:array[0..200] of integer;
begin
randomize;
max:=0;
for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
writeln();
for i:=1 to 200 do begin
if (ar[i] < 0) then ar[i]:=max;
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
професорАртём
01.09.2021 18:25
За какое изобретение дж. бардин, у. шокли, у. браттейн получили нобелевскую премию в 1956 г.?...
Kell500
16.09.2021 06:45
Черно-белое (без градаций серого) растровое графическое изображение имеет размер 10х10 точек. какой информационный объем имеет изображение:...
alinamironova21
13.05.2021 13:47
Нужно вывести эту функцию в main, C++ int GenComb(int* arr, int n, int k) { for(int i = k - 1; i =0; i--) { if (arr[i] n - k + i + 1){ ++arr[i]; for (int j = i + 1; j arr [j] = arr...
MashaEdinorog
07.10.2022 06:36
Текст состоит из 48004800 символов. Известно, что в тексте встречается ровно 200200 различных символов. При сохранении текста в памяти сохраняются коды символов так, что для записи...
Ak1se
02.05.2020 06:16
В компьютерной технике для кодировки символов используется кодировочные таблицы Unicode и ASCII...
MDI1
08.11.2022 20:41
Определить значение переменной b после выполнения фрагмента программы: a:=5; b:=2+a; a:=a*b; b:=2*a-b;...
Alinka04111
07.12.2022 00:39
Определить значение переменной s после выполнения фрагмента программы: s:=5; for i:=4 to 7 do s:=s*2; s:=s-4;...
ruqiyaaminova1
02.02.2023 01:18
Запишите значение переменной s после выполнения фрагмента программы: s:=5; s:=s*2; if s 7 then s:=s*3 else s:=s/2;...
lukash231082
20.01.2022 15:54
Какие размеры площадки должны быть в соревновании роботов Движение по линии ? Варианты ответа: 1. 2600см*3600см 2. 2400см*3800 3. 2800мм*3400 4. 2400мм*3800мм 5. 2800см*3400см...
demon998
25.05.2022 23:22
Какая формула будет получена при копировании в ячейку D3,формулы из ячейки D2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,max:integer;
ar:array[0..200] of integer;
begin
randomize;
max:=0;
for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
writeln();
for i:=1 to 200 do begin
if (ar[i] < 0) then ar[i]:=max;
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;
end.