В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alina1932
alina1932
23.04.2020 13:42 •  Информатика

Дан массив из 30 элементов из интервала[-15;15].Составить программу нахождение суммы отрицательных элементов,больших ответьте

Ответ:
KINGMe
KINGMe
27.01.2022 15:33

pascal

Объяснение:

var i, s: integer;

   a: array[1..30] of integer;

begin

 randomize;

 for i := 1 to 30 do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if (a[i] > -9) and (a[i] < 0) then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма отрицательных элементов,больших -9, равна ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?