Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Lane9ig
10.01.2020 09:26 •
Информатика
Решите в паскале. составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8, r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18, r19, r20 соединение паралельное. сопротивления заданы в массиве, напряжение вводится.
Ответ:
lenayun
25.06.2020 16:16
Uses crt;
const R: array[1..20] of integer =(1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
11, 12, 13, 14, 15, 16, 17, 18, 19, 20);
var I:array [1..20] of real;
U,x:integer;
SUM:real;
begin
write('U='); readln(U);
for x:=1 to 20 do
begin
write('R[',x,']:',R[x],' ');
I[x]:=U/R[x];
SUM:=SUM+I[x];
writeln('I[',x,']:',I[x]:5:3);
end;
writeln('I=',SUM:5:3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Defalt13
20.10.2020 08:58
(2*(a-4*b))/((a-b)-2*a) - формула Выполнить в лазарусе...
крошка44
26.04.2022 23:31
Дано целое число N, а также действительные числа А и Q. Сформировать и вывести целочисленный массив размера N, состоящий из членов геометрической прогрессии, первый член которой...
вира7
03.10.2022 21:14
Как перевести 8 кб в байты? ? можно с расчётом....
vanyanazarenko1
18.03.2020 00:57
в 1 л воды растворили 22,4 л сероводорода. В полученном растворе содержится 0,03:10 катионов водорода. Определить массовую долю и степень диссоциации кислоты....
LERA13511
24.12.2021 06:12
Написать ЭССЕ по вопросам: 1) Как литосфера влияет на хозяйство человека?2) Как гидросфера влияет на жизнь человека?3) Как биосфера влияет на жизнь человека?4) Как атмосфера...
ксения1279мпсалч
06.07.2022 00:36
Поставь существительные в форму родительного падежа множественного числа и заполни таблицу (в одно поле вписывай только одно слово) Не забывай о букве Ё Существительные:кирасир,помидор,эполет,баклажан,обои,погонс...
alice108
09.02.2021 09:51
Еңлік Кебек тура мінездеу,жанама мінездеу...
мαрия
27.12.2022 23:33
Что входит в интерфейс программы ответьте...
никита3343
11.10.2021 08:32
Ідеальна теплова машина має ККД 0 60 %. У скільки разів кількість теплоти, що одержує робоче тіло від нагрівника, більша за кількість теплоти, що віддає робоче тіло холодильнику...
d3ee
09.11.2021 11:18
Перечислите социально опасные объекты Луганска....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const R: array[1..20] of integer =(1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
11, 12, 13, 14, 15, 16, 17, 18, 19, 20);
var I:array [1..20] of real;
U,x:integer;
SUM:real;
begin
write('U='); readln(U);
for x:=1 to 20 do
begin
write('R[',x,']:',R[x],' ');
I[x]:=U/R[x];
SUM:=SUM+I[x];
writeln('I[',x,']:',I[x]:5:3);
end;
writeln('I=',SUM:5:3);
end.