В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
asdsssssssssss124
asdsssssssssss124
26.03.2020 00:23 •  Информатика

, с задачей на с++. Удаление элемента
Удалите из массива элемент в индексом k. Обратите внимание, считывание и вывод массива уже написаны за вас, необходимо написать только фрагмент программы — само удаление элемента.

Входные данные

В первой строке задано натуральное число n (n≤100) и индекс k (0≤k
Примечание

Для того чтобы удалить из массива A последний элемент необходимо использовать инструкцию pop_back():

A.pop_back();
Размер массива уменьшится на единицу. Данная инструкция выдаст ошибку выполнения, если вызвать её на пустом векторе.


, с задачей на с++. Удаление элемента Удалите из массива элемент в индексом k. Обратите внимание, сч

Ответ:
Турик2087
Турик2087
23.01.2022 01:31

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n, k;

   cin >> n >> k;

   vector <int> A(n);

   for (int i = 0; i < A.size(); i++) {

       cin >> A[i];

   }

   A.erase(A.begin() + k);

   for (int i = 0; i < A.size(); ++i) {

       cout << A[i] << " ";

   }

   cout << endl;

   return 0;

}

Объяснение:

Сам не ожидал найти решение в одну строку, удачи! :)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?