В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу для паскаля. дан массив x размера n(n=10) целых чисел, содержащий как положительные, так и отрицательные элементы. упорядочить массив следующим образом: сначала идут отрицательные числа, по невозрастанию, потом положительные, по неубыванию.

Ответ:
Karina902
Karina902
25.06.2020 15:51
Program gt;
var  A,B,C:array[1..1000]of longint;
  p,l,n,i,j,k,w:longint;
begin
n:=10;
for i:=1 to n do
read(A[i]);
k:=0;w:=0;
for i:=1 to n do
begin
if(A[i]<0)then begin
k:=k+1;b[k]:=a[i];
end;
if(A[i]>0)then begin
w:=w+1;
c[w]:=a[i];
end;
end;
for i:=1 to k-1 do
for j:=1 to k-i do
begin
p:=b[j];l:=b[j+1];
if b[j]<b[j+1] then begin
b[j]:=l;b[j+1]:=p;
end;
end;
for i:=1 to k do
write(b[i],' ');
for i:=1 to w do
write(c[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?