В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
EllenOnyschuk
EllenOnyschuk
29.03.2020 16:25 •  Информатика

Массив содержит значения отметок 22 учащихся класса за контрольную работу (случайные числа от 2 до 10).После работы надо ошибками учащиеся переписали работу и получили отметки на выше (кроме тех ,кто получил 10).Составьте программу ,которая выводит отметки ,полученные учениками первоначально и после работы надо ошибками . Pascal

Ответ:
amersjeo
amersjeo
03.12.2021 22:10

const n = 22;

var A: array[1..n] of integer;

var k: integer;

begin

write('До переписывания:');

for var i:= 1 to n do begin

A[i] := 2 + random(9);

write(' ', A[i]);

end;

writeln;

write('После переписывания:');

for var i:= 1 to n do begin

if (A[i] <> 10) then

A[i] := A[i] + 1;

write(' ', A[i]);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?