Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
nnursejt
20.04.2022 08:49 •
Информатика
Дана матрица 5 на 5,надо сделать такую программу которая с каждой строки будет выводить максимальное число. типо ложно так выглядеть 2 3 4 5 6 4 6 3 2 4 5 6 7 8 3 2 5 3 4 6 3 4 5 9 0 первая строка 6 второая 6 третья 8 четвертая 6 пятая 9
Ответ:
Xtarlus
25.06.2020 14:09
Var a:array [1..5, 1..5] of integer; i,j,max:integer;
begin
max:=0;
for i:=1 to 5 do
for j:=1 to 5 do
readln(a[i,j]);
for i:=1 to 5 do begin
for j:=1 to 5 do
if a[i,j]>max then max:=a[i,j];
writeln(t,'= ',max); inc(t); max:=0; end;
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
lediyulia04
14.06.2021 15:03
Впрограмме «: =» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций...
Богдансупе23
11.12.2022 13:47
Задан массив из 10000 элементов. Найти медиану этого массива (Pascal ABC)...
ksutsydmi
15.10.2020 04:58
1,3,5,6,8,9,1011,12,13,15,16,18,19,20,22,23,25,26,28,29,30,31,32,33,34,35...
flillen
21.06.2022 16:54
Пронумеруй команды так. чтобы получился алгоритм. алгоритм сборка чума. начало собрать из шестов деревянную основу чума. порыть чум нюками. снять с саней шесты. снять с саней...
knopendui
21.06.2022 16:54
Тема: pascal.циклы 1)напечатать таблицу умножения на 6(умножение от 1 до 9) 2)найти сумму всех трехзначных чисел,кратных 3 3)вычислить сумму 1+1/2+1/3++1/n...
Pusya102
01.08.2021 06:28
Напишите формулу(одну! ) для excel 2007 г налог = 0, если начислено меньше 1000, 12%, если начислено больше 1000, но меньше 3000, и 20%, если начислено больше или равно 3000...
Yoss12
01.08.2021 06:28
Microsoft excel составить итоговую ведомость по экспертным оценкам (от 0 до 10 ) кандидатов на должность генерального директора фирмы «аква». ведомость должна включать следующую...
lizaivanovamail
01.08.2021 06:28
Пользователь работал с каталогом поэты.сначала он поднялся на один уровень вверх,затем спустился на один уровень вниз,потом еще раз спустился на один уровень вниз. в результате...
Railyna
02.10.2020 21:49
ответить на вопросы в контрольной ! 1.качество растрового изображения, полученного в результате сканирования, зависит от разрешающей сканера. укажите значение, которое имеет...
ruslan2003185
04.10.2021 10:50
Напишите программу, которая “спрашивает” пароль для входа в систему, а после введения пользователем пароля и нажатия кнопки ок выводит окно со значком критической ошибки и...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
max:=0;
for i:=1 to 5 do
for j:=1 to 5 do
readln(a[i,j]);
for i:=1 to 5 do begin
for j:=1 to 5 do
if a[i,j]>max then max:=a[i,j];
writeln(t,'= ',max); inc(t); max:=0; end;
readln;
end.