В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу , которая генерирует N случайных положительных чисел в диапазоне от 1 до Z и находит из сумму , используйте цикл со счётчиком . Необходимо выводить промежуточные результаты сумм )

Ответ:
nekit1205
nekit1205
12.01.2022 15:01

Random ran = new Random();

int N = Console.ReadLine();

int Z = Console.ReadLine();

int[] arr = new arr[N];

int sum =0;

for(int i =0; i<= arr.Length; i++) {

arr[i] = ran.Next(1, Z);

sum+=arr[i];

Console.WriteLine(sum);

}

0,0(0 оценок)
Ответ:
vasukulia
vasukulia
12.01.2022 15:01

Программа:

Python:

from random import uniform

N = int(input('N = '))

Z = float(input('Z = '))

s = 0

for i in range(1, N):

   s += uniform(1, Z)

   print(s)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?