В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Таня5463
Таня5463
01.08.2021 21:41 •  Информатика

1. Автомофные числа. Дано натуральное число N. Напишите программу, которая определяет, является ли число автоморфным. Примечание: Автоморфное число N равно последним разрядам квадрата этого числа: 5 – 25, 6 – 36, 25 – 625. 2. Дан интервал натуральных чисел от N до M. Напишите программу, которая определяет все простые числа в этом интервале.
3. * В магазине продается мастика в ящиках по 15 кг, 17 кг, 21 кг. Напишите программу, которая определяет :
1) Как купить ровно 185 кг мастики, не вскрывая ящики;
2) Сколькими можно это сделать?

4. Тройкой пифагоровых чисел называются натуральные числа для икоторых выполняется равенство а2 + в2 = с2 . Напишите программу, которая находит все тройки пифагоровых чисел, в которых каждое число не превышает значения N, введенного с клавиатуры.
5. Определите количество различных выплаты сдачи в размере n рублей купюрами 10 рублей и монетами 5,2 и 1 рубль. На вход программе подается натуральное число n < 100 – размер сдачи, которую необходимо выплатить. Выведите искомое количество выплаты. Примеры:
Входные данные – 2 Выходные данные - 2
Входные данные – 5 Выходные данные - 4
Язык - Python
, люди добрые

Ответ:
Maxbys
Maxbys
05.01.2022 05:37

Python:

# 1

print(True if int(input()) ** 0.5 % 1 == 0 else False)

# 2

def is_prime(x):

   for d in range(2, x // 2 + 1):

       if x % d == 0: return False

   return True

for number in range(int(input()), int(input()) + 1):

   if is_prime(number): print(number)

# 3

variants = [15, 17, 21]

ways = []

def f(count=0, history=[]):

   if count == 185:

       ways.append(history)

       return 1

   if count > 185: return 0

   return f(count + variants[0], history + [variants[0]]) \

          + f(count + variants[1], history + [variants[1]]) \

          + f(count + variants[2], history + [variants[2]])

result = f()

print(result)

print(*ways[0], sep=' => ')

# 5

ways = []

def f(n, x=0, history=[]):

   if x == n:

       history.sort()

       if history in ways: return 0

       ways.append(history)

       return 1

   if x > n: return 0

   return f(n, x + 10, history+[10]) \

          + f(n, x + 5, history+[5]) \

          + f(n, x + 2, history+[2]) \

          + f(n, x + 1, history+[1])

f(int(input()))

print(len(ways))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?