В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vasapipkin934
vasapipkin934
03.01.2020 21:28 •  Информатика

составить программу, которая формирует массив из 10 случайных целых чисел, принадлежит промежутку [0; 12], выводит на экран исходный массив, затем преобразовывает его, увеличивая чётные значения элементов на 10, и выводит на экран преобразованный массив

Ответ:
NasFan
NasFan
01.01.2022 12:25

Программа:

Pascal:

var

 arr: array[1..10] of integer;

 i: integer;

begin

 for i := 1 to 10 do arr[i] := random(0,12);

 writeln(arr);

 for i := 1 to 10 do if arr[i] mod 2 = 0 then arr[i] := arr[i] + 10;

 writeln(arr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?