В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mara1111176
Mara1111176
04.09.2022 13:19 •  Информатика

решить. Питон или паскаль Алгоритм вычисления функции F(n), где n – целое неотрицательное число, задан следующими соотношениями:

F(n) = 0 при n = 0

F(n) = F(n/2) – 2 при n > 0 для чётных n

F(n) = 2 + F(n–1) при n > 0 для нечётных n

Сколько существует чисел n, меньших 1000, для которых значение F(n) будет равно –2?

Ответ:
tanyagrandf
tanyagrandf
31.12.2021 15:38

ответ: 111

Python:

def F(n):

   if n == 0: return 0

   if n % 2 == 0: return F(n/2) -2

   if n % 2 == 1: return 2 + F(n - 1)

print(len([i for i in range(1000) if F(i) == -2]))

0,0(0 оценок)
Ответ:
Шист
Шист
31.12.2021 15:38

Pascal

Объяснение:

function f(n:integer): integer;

begin

 if n = 0 then

   result := 0

 else

   if n mod 2 = 0 then result := f(trunc(n/2))-2

   else result := 2+f(n-1)

end;

var

  i, k: integer;

begin

 k:=0;

 for i := 1 to 999 do

   if f(i) = -2 then inc(k);

 print(k)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?