Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Inna21042002
23.11.2022 19:55 •
Информатика
Составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие
Ответ:
Колязнаток
25.06.2020 07:29
const
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Анна3481
10.07.2021 00:34
Втурбо паскалі виконайте ! використовуючи підпрограму обчислити довжину кола радіуса 34.2 м....
Амина9505
10.07.2021 00:34
1. что общего и отличного в параметрах раздела, страницы и абзаца? 2. определите разницу между функциями редактирования и форматирования. 3. в каких случаях применяют команды разрыв,...
ojitovtitan
08.02.2023 15:25
Дано целое число n. найдите значение 1 цифры числа это программирование паскаль здесь надо использовать mod и все свои ((...
evtubori
06.07.2020 20:20
Влетнем лагере отдыхало 85 семиклассников. 7 из них не любят компьютерные игры. 55 семиклассника предпочитают квесты, 60 — симуляторы. сколько с одинаковым удовольствием играют и...
диана2263
27.04.2022 08:26
Язабыл графический ключ от телефона orro что мне...
lesikon11
12.01.2020 21:05
Составьте алгоритм сохранения документа в текстовом процессоре. ....
yana603
04.10.2020 00:15
Человек говорит в среднем 8 часов в день и его речь может быть записана 10*118 символами в час. вычислить информационный объем произнесенных человеком слов за 1 год....
plyushka1
04.10.2020 00:15
Подскажите, решение на паскаль по информатике. даны натуральные числа от 1 до 50. найдите сумму тех, которые делятся на 5 и на 7.решите цикл с предусловием и с постусловием, блок...
PORCH1488
04.10.2020 00:15
Почему pascal не видит символ ; ?...
Lalker1337
16.07.2022 21:49
Кислород массой 2 кг занимает объем 1 *10 3 дм 3 при давлении 0,2 мпа. газ нагрели сначала при постоянном давлении до объема 3*10 3 дм 3 , а потом при постоянном объеме до давления...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.