В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
matanya281
matanya281
15.02.2023 22:07 •  Информатика

Python
Компьютер загадывает число. Напишите программу, которая его отгадывает

Ответ:
roma1918
roma1918
25.11.2021 07:30

print("загадайте число!")

x = 0

y = 101

count = 0

print("50")

kod = input()

while kod != "=":

   if kod == "<":

       y = y - (y - x) // 2

       count = y - (y - x) // 2

   if kod == ">":

       x = x + (y - x) // 2

       count = x + (y - x) // 2

   print(count)

   kod = input()

Объяснение:

вы загадываете число

дальше программа вы водит предположительное число

если ваше число меньше этого то вы пишите "<", если больше то вы пишите ">", если программа у гадала ваше число то вы пишите " ="

0,0(0 оценок)
Ответ:
таня1697
таня1697
25.11.2021 07:30

Компьютер загадывает число. Напишите программу, которая его отгадывает. КОМПЬЮТЕР и должен это число отгадывать.

Объяснение:

from random import randint

n=randint(1,100)

print('Компьютер загадал число  ',n)

mn=1

mx=100

s=0

a=-1

while a!=n:

   a=randint(mn,mx)

   s+=1

   if a>n:

       print(a, ' число >')

       mx=a-1

   elif a<n:

       print(a, ' число <')

       mn=a+1

   else:

print(a, 'Угадали. Количество попыток=',s);


Python Компьютер загадывает число. Напишите программу, которая его отгадывает
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?