В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dashab1212200
dashab1212200
12.05.2023 15:47 •  Информатика

1. Напишите программу, которая формирует массив из N целых чисел и выводит на экран сам массив и сумму его элементов. Массив заполняется вводом чисел с клавиатуры.

Протестируйте программу на массивах:

а) 1, 3, 4, -2

б) 0, 1, -2, 10, 11, 12, -10, -3

в) 1, 1, 1, 1, -1, -1, -1, -1

Ответ:
Морфология11
Морфология11
25.11.2021 06:00

На языке Python:

n = int(input('Введите количество элементов N: '))

a = []

for i in range(n):

   a.append(int(input('Введите число: ')))

print('Массив: ', a, 'Сумма элементов: ', sum(a))

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?