В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Moew
Moew
17.03.2022 10:26 •  Информатика

1.составить программу, которая определяет номера позиций символа"," 2. составить программу, которая позволяет заменить все гласные символом "*"

Ответ:
ClarisVerbis
ClarisVerbis
24.06.2020 22:55
{1.}
var
  i: integer;
  s: string;
begin
  write('Введите строку: ');
  read(s);
  writeln('Номера позиций символа ",": ');
  for i := 1 to length(s) do
    if s[i] = ',' then write(i:4);
end.

{2.}
var
  i: integer;  s: string;
begin
  writeln('Введите строку: ');
  read(s);
  for i := 1 to length(s) do
    if s[i] in ['а', 'о', 'э', 'и', 'у', 'ы', 'е', 'ё', 'ю', 'я'] then s[i] := '*';  writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?