В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lyubsretste
lyubsretste
13.07.2022 15:12 •  Информатика

С++ напишите программу которая выводит последнее слово в строке

Ответ:
Kamaria086
Kamaria086
06.11.2021 07:40

using namespace std;

 

 

int main()

{

 string str,tmp;

 getline(cin,str);

 reverse(str.begin(),str.end());

 for(auto&i:str)

 {

   if(i==' ') {break;}

   tmp+=i;

 }

 str.clear();

 reverse(tmp.begin(),tmp.end());

 str=tmp;

 cout<<str<<endl;

 

 system("pause");

}

Объяснение:

надеюсь правильно понял

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?