В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
евген1398
евген1398
05.07.2022 11:09 •  Информатика

Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, и выводится сумма цифр этого числа.
Язык программирования — Python

Ответ:
suhrobiddin98
suhrobiddin98
04.11.2021 17:20

Программа:

Python:

Вариант 1)

N = int(input())

sum = 0

while N > 0:

   j = N % 10

   N //= 10

   sum += j

print(sum)

Вариант 2)

print(sum([int(j) for j in input()]))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?