В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vichkapetrenko
vichkapetrenko
25.05.2020 10:39 •  Информатика

Составить программу суммирования натуральных чисел пока их сумма не превысит величину h. вывести на экран последнее слагаемое и сумму

Ответ:
oleg022
oleg022
24.06.2020 21:44
Readln(n,h);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
0,0(0 оценок)
Ответ:
АннаМарияЛуиза
АннаМарияЛуиза
24.06.2020 21:44
Uses crt;
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?