В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
miroslavakoval2
miroslavakoval2
18.12.2020 16:04 •  Информатика

JAVA☕️ Напишите программу, которая создает массив, элементами которого являются все двузначные целые положительные числа, где и цифра единиц, и цифра десятков делятся без остатка на три. Программа должна поменять местами ближайшие парные и непарные по индексу элементы массива, то есть нулевой элемент меняется с первым, второй элемент меняется с третьим, четвертый с пятым и так далее.
Входные данные: Входящих данных нет.
Выходные данные: Первая строка содержит первичный создан массив, вторая строка - массив с переставленными элементами.
пример:
вывод:
30 33 36 39 60 63 66 69 90 93 96 99
33 30 39 36 63 60 69 66 93 90 99 96

Большое !)

Ответ:
angelinashushina
angelinashushina
18.10.2021 09:10

Відповідь:

public static void main(String[] args) {

     int[]a={30,33,36,39,60,63,66,69,90,93,96,99};

   for(int i=0;i<a.length-1;i+=2){

       a[i]+=a[i+1];

       a[i+1]=a[i]-a[i+1];

       a[i]-=a[i+1];}

   for(int t:a){

   System.out.print(t+" ");}}

Но будьте предельно аккуратны - такой трюк мы может творить только в том случае,если это числа(для чисел с плавающей точкой будут некоторые потери). В другом случае используйте функции обмена.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?