В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Нужно написать программу на языке паскаль. С клавиатуры вводятся длины сторон К
прямоугольников. Посчитать количество вертикально
расположенных и количество горизонтально
расположенных прямоугольников, исходя из того, что
сторона А всегда параллельна оси Х, а сторона В -
оси У.

Ответ:
Тимофей225
Тимофей225
29.11.2021 04:46

var

 a,b,k,i,k1:integer;

begin

 write('Сколько фигур: '); readln(k);

 b:=0; k1:=0;

 for i:=1 to k do

   begin

     write('Стороны ',i,'-го треугольника(A B): '); readln(a,k);

     if a>=k then  

       if a>k then  

         inc(b)

           else inc(k1);

   end;

 writeln('Горизонтальных: ',b);

 writeln('Вертикальных: ',i-b-k1);

 if k1<>0 then

 writeln('Квадратов: ',k1);

end.

Если моё решение вам, пометьте его лучшим !

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?