В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Арина1666
Арина1666
06.01.2021 02:46 •  Информатика

Составьте программу заполнения массива a [1...10] числами Фибоначчи. В последовательности Фибоначчи первый элемент равен нулю, второй - единице, а каждый элемент, начиная с третьего, равен сумме двух предыдущих.

Ответ:
lizaroma224
lizaroma224
05.10.2021 01:00

pascal

Объяснение:

var

  x, y, i: integer;

  a: array[1..10] of integer;

begin

 x := 1; y := 1; a[2] := 1;

 for i := 3 to 10 do

 begin

    y := x + y; x := y - x; a[i] := y;

 end;

 for i := 1 to 10 do Write(a[i], ', ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?