В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
EkaterinaTrenina
EkaterinaTrenina
28.05.2021 23:25 •  Информатика

По данным социологов, из N о человек на улицах Харькова за Партию Программистов собираются голосовать M человек. Используя операцию приведения к типу double, напишите программу, которая по заданным N и социологам определить, сколько процентов респондентов собираются голосовать за Партию Программистов. Резульат представьте в виде целого числа, отбросив дробную часть. на С

Ответ:
Vikak005love
Vikak005love
26.11.2021 01:17

Объяснение:

#include <stdio.h>

#include <math.h>

int main()

{

   int N, M;

   printf("Введите N=");

   scanf("%d", &N);

   printf("Введите M=");

   scanf("%d", &M);

  double result =ceil(((double)M * 100) / (double) N);

  printf("Проценты: %g%%", result);

   

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?