В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
cucuruza5
cucuruza5
31.07.2020 17:31 •  Информатика

Составьте программу, вычисляющую количество цифр введенного натурального числа
Pascal ABC

Ответ:
кристина2161
кристина2161
08.09.2021 22:20

var n, counter : integer;

begin

counter := 0;

writeln('Введите число: ');

readln(n);

while n > 0 do

begin

counter := counter + 1;

n := n div 10;

end;

writeln('Количество цифр в данном числе: ', counter);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?