В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lizka12343
lizka12343
24.04.2021 03:57 •  Информатика

Впаскале сформирвать массив из десяти элементов, заполнить его с генератора случайных чисел и сделать так, чтобы в нем поменялись местами 1 и 2, 3 и 4 значение и так далее. нужно написать программу.

Ответ:
Котик505мяу
Котик505мяу
23.06.2020 23:42
Program Task;
Var a: Array [1..10] of Integer;
    i, tmp: Integer;
Begin
    Randomize;
    WriteLn('Сформированный массив:');
    For i := 1 To 10 Do
    Begin
        a[i] := Random(10);
        Write(a[i], ' ');
    End;
    WriteLn;
    For i := 1 To 5 Do
    Begin
        tmp := a[i * 2];
        a[i * 2] := a[i * 2 - 1];
        a[i * 2 - 1] := tmp;
    End;
    WriteLn('Измененный массив:');
    For i := 1 To 10 Do
        Write(a[i], ' ');
    ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?