В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
miras39
miras39
28.01.2020 21:35 •  Информатика

На питоне без использования if и while Ваня наблюдает за лягушкой

Ваня наблюдает за лягушкой. Изначально она сидит в точке 0 числовой прямой. Каждую секунду она прыгает на 1 вправо, пока не достигнет точки K. Затем она начинает каждую секунду прыгать на 1 влево, пока не вернется в точку 0, затем – опять вправо и т. д. Требуется определить, где окажется лягушка через T секунд.

Входные данные

Вводятся два числа K и T, разделенные пробелом. Оба числа натуральные и не превосходят 1 000 000 000.

Выходные данные

Вывести одно число – координату лягушки в момент времени T.

Ответ:
semabulov
semabulov
15.08.2021 01:00

k, t = [int(i) for i in input().split()]

a = t % k

b = t // k

m = k - a

c = t

for i in range(b):

   c = m

   g = m

   m = a

   a = g

print(c)

Объяснение:

попробуй это

0,0(0 оценок)
Ответ:
MasterHacker
MasterHacker
14.09.2021 01:49

Pascal:

var

k,t,x: integer;

begin

readln(k, t);

x := abs(t mod k - k*sqr(t div k and 1));

writeln(x);

end.

Python:

k, t = input().split()

print(abs(int(t) % int(k) - int(k) * (int(t) //  int(k) and 1) ** 2))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?