В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел)

Ответ:
DariaShistad18
DariaShistad18
23.06.2020 20:27
Var
    a, b, c, d: integer;

function max(i1, i2: integer): integer;
begin
    if i1 > i2 then max := i1 else max := i2;
end;

begin
    read(a, b, c, d);
    writeln(max(max(max(a, b), c), d));
end.

не помню как процедуры писать, но с функциями даже удобнее
0,0(0 оценок)
Ответ:
dbnzgh
dbnzgh
23.06.2020 20:27
Program ufhg;
uses crt;
var a,b,c,d, m: integer;
begin 
readln(a,b,c,d);
m:=a;
if(b>m) then m:=b;
if(c>m) then m:=c;
if(d>m) then m:=d;
writeln(m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?