В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Алекс23102027
Алекс23102027
21.04.2022 15:07 •  Информатика

Меньше среднего.C++ Дан массив A из N элементов. Требуется найти и вывести количество элементов,
значение которых меньше среднего арифметического значения элементов массива.
Input
Со стандартного устройства ввода в первой строке вводится целое число
N (1 <= N <=1000) — количество элементов массива. Во второй строке через пробел
вводятся N целых чисел - элементы массива A (-1000 <= A i <= 1000).
Output
Требуется вывести целое число - количество искомых элементов. Выводить в конце
строки пробел не нужно.
Sample Input
5
2 4 6 10 8
Sample Output
2
Примечание
Среднеe арифметическое значение элементов массива =
(Сумма значений всех элементов массива) / (Количество элементов в массиве).
В примере среднеe арифметическое значение = (2 + 4 + 6 + 10 + 8) / 5 = 6.

Ответ:
Irishagogo
Irishagogo
27.08.2021 13:23

#include <iostream>

using namespace std;

int main() {

   int N;

   cin >> N;

   int* arr = new int[N];

   int sum = 0;

   for (int i = 1; i <= N; ++i) {

       cin >> arr[i - 1];

       sum += arr[i - 1];

   }

   int count = 0;

   for (int i = 0; i < N; ++i) {

       if (arr[i] < (sum / N))

           ++count;

   }

   cout << count;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?