В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
viktoria20000000
viktoria20000000
16.01.2021 23:36 •  Информатика

Напишите программу, в которой создается список из нескольких элементов и потом этот список выводится на печать в виде таблички индекс – значение

питон

Ответ:
gnbufa
gnbufa
26.08.2021 15:23

№1

a = [int(input('Введите значение: ')) for _ in range(int(input('Введите кол-во значений: ')))]

for i in range(len(a)):

   print('индекс ', i, ', значение ', a[i], sep='')

№2

a = [int(input('Введите значение: ')) for _ in range(int(input('Введите кол-во значений: ')))]

a.reverse()

for i in range(len(a)):

   print('индекс ', i, ', значение ', a[i], sep='')

№3

import random

print([random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))])

№4

import random

a = [random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))]

print(a)

print('Выручка составляет', sum(a), 'рублей')

№5

import random

a = [random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))]

print(a)

print('Выручка составляет', sum(a), 'рублей')

print('Сумма наибольшей покупки составляет', max(a), 'рублей')

print('Сумма наименьшей покупки составляет', min(a), 'рублей')

№6

import random

a = [random.randrange(1, 50) for _ in range(int(input('Введите кол-во покупок: ')))]

print('')

print('| Число | Сумма от 1 до числа |')

for i in range(len(a)):

   print('')

   print('|', a[i], ' | ', sum(range(1, a[i]+1)), ' |')

print('')

Тут можно поиграть с таблицей, чтобы было хорошо было видно, а значения верные.

№7

import random

a = [random.randrange(1, 100) for _ in range(random.randrange(10, 20))]

b = int(input('Введите ограничение: '))

q = []

print(a)

for i in a:

   if i < b:

       q += [i]

print(q)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?