В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
холера673
холера673
06.01.2020 07:35 •  Информатика

С++. Напишите программу, которая находит количество элементов, равных максимальному. Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 . Программа должна вывести два числа, разделив их пробелом: максимальный элемент массива и количество элементов массива, равных максимальному. Без массивов

Ответ:
NastyKot15246
NastyKot15246
19.08.2021 20:19

#include <iostream>

using namespace std;

int main() {

    int N, count=0;

    long long max;

    // создаем и заполняем массив

    cin>>N;

    long long* array=new long long[N];

    for(int i=0; i<N; i++)

        cin>>array[i];

    //находим максимальный элемент

    for(int i=0; i<N; i++)

    {

        if(i==0)

            max=array[i];

        else if(array[i]>max)

            max=array[i];

    }

    //считаем элементы, равные максимальному

    for(int i=0; i<N; i++)

        if(array[i]==max)

            count++;

    //выводим результат

    cout<<max<<" "<<count;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?