В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dashka1035
dashka1035
25.03.2022 05:09 •  Информатика

№9. Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.
Входные данные
Входная строка содержит два целых числа.
Выходные данные
Программа должна вывести произведение введённых чисел

Ответ:
lushkina73
lushkina73
15.08.2021 18:20

1 Вариант:

numbers=list(map(int,input().split()))

if numbers[0] == 0 or numbers[1] == 0:

   print(0)

else:

   print(numbers[0]/(1/numbers[1]))

2 Вариант:

numbers=list(map(int,input().split()))

summ=0

if numbers[1]<0 and numbers[0]<0:

   for i in range(-numbers[0]):

       summ+=-numbers[1]

elif numbers[1]<0:

   for i in range(numbers[0]):

       summ+=numbers[1]

else:

   for i in range(numbers[1]):

       summ+=numbers[0]

print(summ)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?