В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
556667888
556667888
05.10.2020 18:09 •  Информатика

Составить программу на языке С++. Создать класс с указанными двумя полями и методом. Привести пример использования (вызов) указанного класса. Поле 1: Вещественное число — а Поле 2: Вещественное число - b Метод: Вычислить сумму квадратов чисел

Ответ:
keshacold691
keshacold691
13.08.2021 09:43

class MyClass

{

   public:

       float a,b;

       MyClass() {}

       float SumQuad()

       {

           return a * a + b * b;

       }  

};

int main()

{

   MyClass MyClassExamp;

   std::cin >> MyClassExamp.a >> MyClassExamp.b;

   std::cout << MyClassExamp.SumQuad() << std::endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?