В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
romaantonizin1
romaantonizin1
22.03.2022 19:42 •  Информатика

Решить : 1. составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. 2. составьте программу, которая организует ввод массива а [1..8] с клавиатуры, затем преобразовывает массив, заменяя все отрицательные элементы их модулями.

Ответ:
syedelifozq8ou
syedelifozq8ou
23.06.2020 19:54
Задача 1.
Var a,z:integer;
m:array[1..10] of integer;
begin
for a:=1 to 10 do
m[a]:=random(10)+1;
z:=m[1];
m[1]:=m[10];
m[10]:=m[z];
end.
Задача 2
var a:array[1..8]of integer;
i:integer;
begin
for i:=1 to 8 do
readln(a[i]);
for i:=1 to 8 do
if a[i]<0 then a[i]:=abs(a[i]);
writeln;
for i:=1 to 8 do
write(a[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?