В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
katehell11
katehell11
08.02.2023 11:17 •  Информатика

Написать программу для расчета суммы ​


Написать программу для расчета суммы ​

Ответ:
owlllllll
owlllllll
29.07.2021 13:42

Объяснение:

На Паскале:

program Fproj;

 var

   k,n:integer;

   S:Double;

function F(n: integer):integer;

var i:integer;

begin

    F := 1;

    for i:=2 to n do

       F := F * i;

   end;

begin

   readln(n);

   s:=0;

for k:=1 to n do

 begin

  S:=S+(F(k)+5)/F(k+1);

 end;

 writeln('S= ',S:5:2);

 readln;

end.                      

0,0(0 оценок)
Ответ:
Ваниш20
Ваниш20
29.07.2021 13:42

Free Pascal

а вот при рекурсии

var

n, k: longint;

s : double;

function fact(x:longint): longint;

begin

  if x=0 then fact:=1

  else fact:=fact(x-1)*x;

end;

begin

 writeln('Введите n:');

 readln(n);

 s:=0;

 for k := 1 to n do

    s:= s + (fact(k)+5)/fact(k+1);

 writeln(s:4:4)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?