В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
secret666
secret666
18.04.2020 08:16 •  Информатика

Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную

Ответ:
alenamarishchu
alenamarishchu
01.10.2020 12:27

#include <iostream>

#include <string>

#include <cmath>

using namespace std;

void main(void){

setlocale(LC_ALL, "rus");

int i,sum=0,n,r=0;

char date[255];

cout << "Введите двоичное число"<< endl;

cin >> date;

n = strlen(date);

int *arr = new int[n];


for (i = 0; i < n; i++){

 arr[i] = (int)date[i] - (int)'0';

}

for (i = 0; i < n; i++){

 cout << arr[i] << " ";

}

cout << " " << endl;

for (i = 0; i < n; i++){

 r = r + arr[i]*pow(2, n - i-1);

}

cout << "Десятичное число равно" << r;


}


Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?