В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
474886
474886
19.05.2020 03:24 •  Информатика

Написать программу, которая вводит двумерный массив 3х3 из целых чисел, выводит его на экран в виде матрицы, а затем выводит квадратный корень из каждого элемента. 8 3 5
9 3 8
9 4 3

Ответ:
998974452408
998974452408
27.07.2021 18:34

Free Pascal

const

 n=3;

var

 a : array [0..n-1, 0..n-1] of integer;

 i, j : integer;

begin

(* тут вводим массив поэлементно *)

 writeln('Введите массив A: ');

 for i:=0 to n-1 do

   for j:=0 to n-1 do begin

     write('a[',i,',',j,']=');

     readln(a[i,j]);

   end;

(* печатаем массив в виде матрицы*)

 for i:=0 to n-1 do begin

   for j:=0 to n-1 do

     write(a[i,j], ' ');

   writeln;

 end;

(* печатаем в виде матрицы корни из каждого соответствующего элемента*)

 for i:=0 to n-1 do begin

   for j:=0 to n-1 do

     write(sqrt(a[i,j]):2:2, ' ');

   writeln;

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?