В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Yuliya12222222222
Yuliya12222222222
25.08.2020 17:59 •  Информатика

Решите 2 программы. 1) найдите количество двухзначных чисел, которые делятся на сумму своих цифр. 2) составьте программу вычисления количества трехзначных чисел, у которых сумма цифр является чётным числом. !

Ответ:
К123
К123
23.06.2020 19:10
1)uses crt;
var i,k:integer;
begin
for i:=10 to 99 do
if i mod ((i mod 10)+(i div 10))=0 then inc(k);
writeln(k);
end.
2)uses crt;
var i,k:integer;
begin
for i:=100 to 999 do
if ((i mod 10)+(i div 100)+ ((i div 10)mod 10)) mod 2=0 then inc(k);
writeln(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?