В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
minikotik322
minikotik322
16.07.2021 13:49 •  Информатика

Написать программу в питоне через списки(только через списки, никак иначе) дать подробное пояснение к программе


Написать программу в питоне через списки(только через списки, никак иначе) дать подробное пояснение

Ответ:
nadyarn
nadyarn
16.07.2021 23:52

import random

#если нужен ручной ввод - matrix=[[int(input(str(i+1)+" группа " + str(x+1) + " курса: ")) for i in range(6)] for x in range(5)]

matrix=[[random.randint(1,26) for i in range(6)] for x in range(5)]

print(matrix) #чисто для проверки, можно стереть

#запись промежуточных переменных для вычисления минимума

minimum=1000

minimum1=minimum

minimum_grop_list=[]

for i in range(5): #главный цикл, который идет по курсам

   if sum(matrix[i])<minimum: #суммирует количество людей во всех группах курса и ищет наименьшее

       minimum=sum(matrix[i])

       minimum_year=i+1

   minimum2=1000 #тут переменная с каждым курсом перезаписывается для того, чтоб искать наименьшее в каждом из курсов

   for x in range(6): #цикл по курсу, перебирает группы

       if matrix[i][x]<minimum2: #поиск наименьшего в курсе

           minimum2=matrix[i][x]

           minimum_group1=x+1

       if matrix[i][x]<minimum1: #поиск самой наименьшей группы

           minimum1=matrix[i][x]

           minimum_group=x+1,i+1

   minimum_grop_list.append(minimum_group1)

print("a)",minimum_year) #выводит курс

print("б)",*minimum_group) #выводит номер группы, потом курс

print("в)", *minimum_grop_list) #выводит наименьшие группы в каждом из курсов

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?