В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Uorent
Uorent
17.02.2022 00:36 •  Информатика

Напишите программу на Python, которая бы вычисляла нумерологическое число (складываются числа даты рождения, до тех пор, пока не получится число от 1 до 9, допустим 23.01.2001 = 2 + 3 + 0 + 1 + 2 + 0 + 0 + 3 = 11 = 1 + 1 = 2. Нумерологическое число = 2.

Ответ:
эля821
эля821
15.07.2021 00:35

date=input()

numb=0

while not 0<numb<10:

   numb=0

   for i in date:

       if i.isdigit():

           numb+=int(i)

   date=str(numb)

print(numb)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?