В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
fogive
fogive
30.12.2021 17:38 •  Информатика

Ввести с клавиатуры квадратный двумерный массив целых чисел, содержащий nстрок и столбцов, и вывести его на экран в виде классической матрицы. написать программу в питоне(на всякий случай)
дать пояснение к программе

Ответ:
Ника290305
Ника290305
13.07.2021 18:12

Python

# задаём размерность матрицы

n=int(input('Введите n: '))

# задаём размерность матрицы

a=[[0 for i in range(n)] for j in range(n)]

# заполняем матрицу

for i in range(n):

 for j in range(n):

     a[i][j]=int(input("a[{}][{}]=".format(i,j)))

# выводим матрицу построчно, для формирования в класическом виде

for i in a: print(i)


Ввести с клавиатуры квадратный двумерный массив целых чисел, содержащий nстрок и столбцов, и вывести
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?