В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maksnemolyaev
maksnemolyaev
13.06.2022 17:09 •  Информатика

На С++ написать программу Дано натуральное число. Определить, сколько раз в нём встречается первая цифра.

Ответ:
VeronaKotik
VeronaKotik
11.07.2021 22:41

#include <iostream>

using namespace std;

 

int main()

{

   int N, N1, count=0;

   

   cout << "N="; cin >> N;

   

   N1=N;

   

   while (N>=10)  

   {  

       N/=10;

   }

   

   while (N1)  

   {

       if(N1%10==N) count++;

       N1/=10;

   }

   

   cout << "count=" << count << "\n";

   

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?