В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kacok2
kacok2
16.02.2023 01:49 •  Информатика

Задача 126: Кубическое уравнениеНапишите программу, которая будет искать все целые x, удовлетворяющие уравнению:Ax3 + Bx2 + Cx + D = 0, где A, B, C, D — заданные целые числа.Формат входных данных. Во входном файле записаны четыре целых числа: A, B, C, D. Всечисла по модулю не превышают 2*109 .Формат выходных данных. В выходной файл выведите сначала количество решений этогоуравнения в целых числах, а затем сами корни в порядке возрастания. Если уравнение имеетбесконечно много корней, выведите в выходной файл одно число -1 Методом ооп решить надо, обычным я понимаю как решать, но оопшным не понимаю:)

Ответ:
Hause1
Hause1
10.07.2021 23:02

a, b, c, d = map(int, input().split())

c = 0

A = []

if a + b + c + d > 0:

   print(0)

else:

   for x in range(-100000, 1000000 + 1):

       if a * x ** 3 + b * x**2 + c * x + d == 0:

           c += 1

           A.append(x)

           if c > 30:

               break

   if c > 30:

       print(-1)

   else:

       print(c)

       for i in range(len(A)):

           print(A[i])

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?